[Cairo] Semantics of cairo_copy changed in 0.1.7

Carl Worth cworth at east.isi.edu
Tue Sep 30 12:04:01 PDT 2003

On Sep 30, Carl Worth wrote:
 > 	void
 > 	cairo_copy (cairo_t *dst, cairo_t *src);

I've gone ahead and committed this (0.1.7).

 > I think that should be clear enough without the words "graphics" or
 > "state".

The one thing that is perhaps not obvious from the name cairo_copy is
that only the current "graphics state" is copied, not the entire
stack. Obviously we'll address that in documentation. Though, the
following two questions come up about the name:

1) Would we ever want to have a stack-copying version? If so, it
   should get the name cairo_copy. I don't see how it would be useful,
   but I often underestimate what users will want to do.

2) Would it be significantly easier to document the non-stack-copying
   nature of the function if it had a name like cairo_copy_state? If
   not, I prefer sticking to the shorter name of cairo_copy.


More information about the cairo mailing list