Billy Biggs vektor at dumbterm.net
Sun Aug 21 13:18:13 PDT 2005

  The macros CAIRO_CONTENT_VALID and CAIRO_FORMAT_VALID are currently
defined in the public API, and I would like to propose removing them.

  1. They're macros which will be invalid in compiled code if the enums
     are expanded
  2. Wrapper APIs which use them for sanity checking will fail if their
     clients somehow use some new types added in the future
  3. They're not all that useful
  4. Similar macros don't exist for many of the other types

  However, this would be a very last-minute change and could break


More information about the cairo mailing list