[cairo] Problems porting to embedded ARM9 platform - only rectangles are visible

Daniel Amelang daniel.amelang at gmail.com
Wed Dec 20 17:21:30 PST 2006

On 12/19/06, Luke Diamand <luke at diamand.org> wrote:
> Hi!
> I'm trying to get cairo 1.3.8 running on an embedded ARM9 platform (no
> FPU; gcc 3.4, little-endian).
> I find that only rectangles get displayed correctly. Diagonal lines and
> arcs never appear. The same code works fine on x86/linux.
> I ran the fill_rule test, and it said:
> 4224 pixels differ (with maximum difference of 255) from reference image
> TEST: fill-rule TARGET: image FORMAT: argb32 OFFSET: 0 RESULT: FAIL
> fill-rule-image-argb32 [0]:     FAIL
> etc.
> I've tried enabling the various debug options available, but without
> much luck.
> Is there anything I can do to diagnose this problem further?

That's pretty bizarre. We already have cairo 1.3.8 running properly on
the 770, which has pretty much the same hardware specs. I'll fire mine
up later to see if we missed a "make test" back there.

Can you tell us more about your system? Hardware and software? What
are the major differences when compared to the 770 and Maemo?


More information about the cairo mailing list