[cairo] clip-getters [patch]

Robert O'Callahan rocallahan at novell.com
Mon Sep 25 20:22:45 PDT 2006

On Mon, 2006-09-25 at 16:50 -0700, Carl Worth wrote: 
> > +typedef struct _cairo_rectangle_list {
> > +} cairo_rectangle_list_t;
> ...
> > +cairo_public void
> > +cairo_rectangles_destroy (cairo_rectangle_list_t *rectangle_list);
> There's an inconsistency here between "rectangle_list" in the type name
> and "rectangles" in the function name. Those should be made to
> match. An argument against "rectangle_list" is that this is an array,
> not a list. An argument against "rectangles" is that its remarkably
> similar to "rectangle".

I vote for rectangle_list. An array is just an implementation of a
list :-).

I'll fix that and get vlad to push it. Thanks!


More information about the cairo mailing list