[cairo] clip-getters [patch]
cworth at cworth.org
Fri Sep 29 15:46:51 PDT 2006
On Tue, 26 Sep 2006 15:22:45 +1200, Robert O'Callahan wrote:
> I vote for rectangle_list. An array is just an implementation of a
> list :-).
> I'll fix that and get vlad to push it. Thanks!
It looks like this got pushed without any change in this area.
I think I like the function name that got pushed
(cairo_copy_clip_rectangles) more than I would like
I can imagine we might add a cairo_copy_clip that returns a
cairo_path_t and then cairo_copy_clip_rectangles would just be a
variant of that, (much like cairo_copy_path_flat is a variant of
cairo_copy_path). So keep the variant consistently as a single-word
would be nice.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 189 bytes
Desc: not available
Url : http://lists.freedesktop.org/archives/cairo/attachments/20060929/a8024eac/attachment.pgp
More information about the cairo