[cairo] clip-getters [patch]
cworth at cworth.org
Fri Sep 29 17:55:46 PDT 2006
On Fri, 29 Sep 2006 17:34:00 -0700, Carl Worth wrote:
> On Fri, 29 Sep 2006 20:21:47 -0400 (EDT), Andrew Johnson wrote:
> > Or it could be that I am possibly being just a bit pedantic.
> No, it's a good point you're making.
Particularly good since _list (or something similar) could be applied
consistently to any datatype. Whereas if we went with "rectangles" we
would set ourselves up with a nasty precedent if we ever wanted to
mimic this pattern in the future, (and were unlucky enough to find
ourselves with an irregular English plural).
> Oh, and Robert, I forgot to mention this before, but new API also
> needs to have a Since: tag in the documentation to indicate the first
> release that contains it. Particularly since I went and just pushed
> out our documentation to the web site (oops).
I've gone ahead and added "Since: 1.4" to all the symbols I could see
that were obviously missing it. I did this by browsing the changes in
public header files since 1.2.4 [*]:
I notice that we don't have anything like this for the experimental
backend functions, (and maybe that's OK---maybe we're not even putting
documentation for those on the web at all?). Those do "leak" a bit int
cairo_surface_type_t so maybe it would make sense to add some Since:
tags there still, (there are currently none on that enum).
[*] Using the recipe documented in cairo/RELEASING:
find src/ -name '*.h' -not -name '*-private.h' -not -name '*-test.h' \
-not -name 'cairoint.h' | xargs git log -p 1.2.4.. --
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 189 bytes
Desc: not available
Url : http://lists.freedesktop.org/archives/cairo/attachments/20060929/7eda2479/attachment.pgp
More information about the cairo