[cairo] clip-getters [patch]

Robert O'Callahan rocallahan at novell.com
Sat Sep 30 02:27:30 PDT 2006

On Fri, 2006-09-29 at 15:46 -0700, Carl Worth wrote:
> On Tue, 26 Sep 2006 15:22:45 +1200, Robert O'Callahan wrote:
> > I vote for rectangle_list. An array is just an implementation of a
> > list :-).
> >
> > I'll fix that and get vlad to push it. Thanks!
> It looks like this got pushed without any change in this area.
> I think I like the function name that got pushed
> (cairo_copy_clip_rectangles) more than I would like
> cairo_copy_clip_rectangle_list.

It was an oversight. I did rename the destructor to

Based on the other emails in this thread, it seems best to rename
cairo_copy_clip_rectangles to cairo_copy_clip_rectangle_list. OK?


More information about the cairo mailing list