[cairo] ./configure failing on $PKG_CONFIG --exists $l

Behdad Esfahbod behdad at behdad.org
Thu Jan 4 12:31:10 PST 2007

On Thu, 2007-01-04 at 14:51 -0500, Todd Wade wrote:
> Hi,
> I'm on CentOS 4.
> when running ./configure I'm getting the following error:
> checking for cairo's PNG backend...
> ./configure: line 24790: --exists: command not found
> ./configure: line 24790: --exists: command not found
> ./configure: line 24790: --exists: command not found
> configure: WARNING: Could not find libpng in the pkg-config search
> path
> checking whether cairo's PNG backend could be enabled... no
> configure: error: requested PNG backend could not be enabled
> I tried to run configure as follows, but I get the same error:
> ./configure png_CFLAGS=`libpng-config --cflags`
> png_LIBS=`libpng-config --libs`
> Running each of the args seperately gives:
> [root at www cairo-1.2.6]# libpng-config --cflags
> -I/usr/include/libpng12
> [root at www cairo-1.2.6]# libpng-config --libs
> -lpng12
> Will someone please suggest the magic encantation needed to get
> configure to suceed for cairo?

The problem is that cairo 1.2.6 requires pkg-config >= 0.19.  However,
the requirement is bogus.  So you can replace the following line in




and run autoconf, then proceed with normal configure process.

> Thank you for your time!
> Todd W.


"Those who would give up Essential Liberty to purchase a little
 Temporary Safety, deserve neither Liberty nor Safety."
        -- Benjamin Franklin, 1759

More information about the cairo mailing list