[cairo] ./configure failing on $PKG_CONFIG --exists $l

Todd Wade trwww at sbcglobal.net
Thu Jan 4 11:51:21 PST 2007


I'm on CentOS 4.

when running ./configure I'm getting the following error:

checking for cairo's PNG backend...
./configure: line 24790: --exists: command not found
./configure: line 24790: --exists: command not found
./configure: line 24790: --exists: command not found
configure: WARNING: Could not find libpng in the pkg-config search path
checking whether cairo's PNG backend could be enabled... no
configure: error: requested PNG backend could not be enabled

I tried to run configure as follows, but I get the same error:

./configure png_CFLAGS=`libpng-config --cflags` png_LIBS=`libpng-config --libs`

Running each of the args seperately gives:

[root at www cairo-1.2.6]# libpng-config --cflags
[root at www cairo-1.2.6]# libpng-config --libs

Will someone please suggest the magic encantation needed to get configure to suceed for cairo?

Thank you for your time!

Todd W.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.freedesktop.org/archives/cairo/attachments/20070104/798839a2/attachment.html

More information about the cairo mailing list