[cairo] assertion - locking problem in multithreaded app

Jan Slupski jslupski at gmail.com
Tue Jan 16 13:26:16 PST 2007

Hi Cairo,

Recently I've been testing an application with cairo underlying
and hit assertions that seems to be locking problems described
here https://bugs.freedesktop.org/show_bug.cgi?id=8801 and
here http://lists.freedesktop.org/archives/cairo/2006-December/008945.html

I have tried the patch that is attached to the bugzilla report and it helped
much (after fixing it a bit - see my comment on the bottom of bugzilla),
but another assertions still happens.

This time it is 'assert (unscaled->lock > 0);' in 

I guess this may be related to Behdad suggestion 'This bug suggests that 
the same
is happening in cairo_ft_scaled_font_lock/unlock'.

Are there any works done to fix this. Is there anything I could do to help?

I'm very interested in having multithreading problems in Cairo solved
(even if it will be not in the most efficient way for now), so if there
were no further works on this beyond above thread and bugzilla entry,
I'll try to code suitable workaround myself.
But maybe you've done something already or have any suggestions?

Jan Slupski

More information about the cairo mailing list