[cairo] Cross-built Cairo for ARM not drawing

Marc Singer elf at synapse.com
Fri Mar 14 11:15:28 PDT 2008

Leon Woestenberg wrote:
> Hello Marc,
> On Fri, Mar 14, 2008 at 2:11 AM, Marc Singer <elf at synapse.com> wrote:
>> I've been using cairo 1.2.4 for some time because it was the only
>>  version that was drawing for me.  Today, I tried 1.4.14 again and
>>  1.5.12 just to see if I could determine why I've had problems in the past.
>>  I'm cross building for ARM using GCC-3.4.4.
>>  The 1.4.14 build tends to draw narrow vertical bands of color.
>>  Version 1.5.12 with pixman 0.9.6 doesn't show those bands of color, but most
>>  of the time the drawing is blank.  I've reduced the code to a simple
>>  example:
> In openembedded(.org), we have cairo graphics working perfectly on ARM
> and PowerPC, and the revisions we tested are listed here:
> http://www.openembedded.org/filebrowser/org.openembedded.dev/packages/cairo
I'll look at your packages.
>>  Any suggestions as to where to look for such a problem?  BTW, I am
>>  configuring cairo without most of the backends:
> This sounds like a toolchain problem, most probably either endianess
> related, or more probably (soft?) floating point related.
> I would strongly suggest to run some floating point tests on your target first.
> Personally, I mostly use a ARM/XScale (arm5teb) target, and PowerPC
> (e300) target in combo with cairo, no problems so far.
> Regards,
It would be odd that the toolchain worked on 1.2.4 and didn't work on 
the others.
We're using soft-float and the target is armv4l.

Marc Singer
Bureau of Gizmology
elf at synapse.com
t. 206.832.3712
f. 206.381.0899

Synapse Product Development, LLC.
1511 6th Avenue, 4th floor
Seattle, WA 98101

More information about the cairo mailing list