[cairo] GSoC: Scan converting rasteriser update

Jeff Muizelaar jeff at infidigm.net
Mon Nov 17 07:19:33 PST 2008

On Mon, Nov 17, 2008 at 01:12:18AM +0200, M Joonas Pihlaja wrote:
> New stuff still on the TODO list:
> 1. Rename the span_renderer->init method to 
> ->set_composite_rectangles() to clarify the intent of the method.
> 2. Use an errror span renderer object on creation failure instead 
> of returning NULL.
> 3. Split up the the backend make_span_renderer() into two to 
> reflect the two usages: querying the backend to see if it wants 
> to make the requested span renderer and actually making it. 
> Naming suggestions welcome (can_make_span_renderer() ?)

maybe can_span_render() or can_render_spans()

> 4. Improve the quality of comments in cairo-tor-scan-converter + 
> naming issues: Add a general outline / theory of operation 
> section, remove redundant function comments, and explain some of 
> the tricky bits better.
> Does that sound about right?  I'll ping the list when it's all 
> pushed to my cairo repo.  Hopefully in the next few days.

Sounds good.


More information about the cairo mailing list