[cairo] GSoC: Scan converting rasteriser update
cworth at cworth.org
Mon Nov 17 14:12:17 PST 2008
On Mon, 2008-11-17 at 10:19 -0500, Jeff Muizelaar wrote:
> On Mon, Nov 17, 2008 at 01:12:18AM +0200, M Joonas Pihlaja wrote:
> > 3. Split up the the backend make_span_renderer() into two to
> > reflect the two usages: querying the backend to see if it wants
> > to make the requested span renderer and actually making it.
> > Naming suggestions welcome (can_make_span_renderer() ?)
> maybe can_span_render() or can_render_spans()
I like the split. It's a great idea.
I don't have strong feelings about what the naming is here, (though I
guess we've used "has" more than "can" in similar place. One thing I
would like to see is that there's some common substring that matches
between the two names. For example, I would not like to see
make_span_renderer and can_render_spans, (because "span_renderer" and
"render_spans" don't match).
A couple of verbs that we use inside EXA are "check" and "do" for the
prefixes, and then some common name afterwards. So there's one thing
that would look familiar to me. But again, I have no strong feelings
here about the actual name, (it's internal API so we can always change).
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://lists.cairographics.org/archives/cairo/attachments/20081117/e4fe283c/attachment.pgp
More information about the cairo