[cairo] Simple suggestion to improve index

Daniel Goldman dagoldman at yahoo.com
Sat Aug 21 12:40:59 PDT 2010

Each line in the cairo index at http://cairographics.org/manual/index-all.html 
seems to have the same redundant format (name, linked name) as follows :

cairo_antialias_t, enum cairo_antialias_t
cairo_append_path, cairo_append_path ()
cairo_arc, cairo_arc ()
cairo_arc_negative, cairo_arc_negative ()
cairo_bool_t, cairo_bool_t

I think this is kind of a technical writing "horror story"! cairo has a great 
index, but the formatting really misses the boat.

I would suggest the following format (just the linked name) is more legible, 
easier to read, and easier to search.

cairo_append_path ()
cairo_arc ()
cairo_arc_negative ()
enum cairo_antialias_t

One difference is the enums would group together. But I think that would be 
better. I would go even further, and group all the macros together, all the 
structs together etc. But all I'm really asking for in this post is to simply 
remove the redundancy.

Does anyone disagree the second format is better? Am I missing something? Even 
if gtk-doc is so pitiful that it does not allow this kind of formatting option, 
I believe a simple sed command in a wrapper shell script could make the change.

More information about the cairo mailing list