[cairo] Cairo, pango and Win32.. incorrect font rendering

Peter Clifton pcjc2 at cam.ac.uk
Sat Jan 16 16:26:41 PST 2010

On Sat, 2010-01-16 at 14:12 +0000, Peter Clifton wrote:
> Hi guys,
> Vague I know, but I wondered if this rang any bells.
> The gEDA suite (electronic design tools) now uses cairo and pango to
> render its schematics. This works really well on Linux, and on Mac OSX
> when the right magic is used to build it.
> However, I've just cross-built for Win32, which has worked in the past,
> and have had reported issues of text rendering at the wrong size.
> (See screen-shot here:
> http://www.xs4all.nl/~ljh4timm/downloads/gschem-1.6.0_add_text_testing.png
> )
> The same program works fine under Wine, but fails under Win32. No other
> font rendering in the program, or the toolkit is affected.
> I built with pango-1.26.0 and cairo 1.8.8.
> Configure logs attached.
> Does anyone have any ideas how to debug this (I have no access to a
> Windows machine), or ideas as to what might be wrong?

Ok, I dug out my old broken laptop (screen broken), found its original
HDD (which still had XP installed on it), soldered fatigued PSU cable..
attached an external screen...

I was able to test the same code as my bug reporter (same installer
package), and it worked fine for me. Does that give any more clues? I'm
frustrated that I can't reproduce it (after a lot of effort to setup the

I then updated the the latest XP service pack, and the problem is still
absent. I can only figure that something extraneous is getting in the
way on my reporter's machine - but I don't know what to try next -
either to fix his setup, or to reproduce the bug here.

All ideas appreciated,

Best wishes,

Peter C.

More information about the cairo mailing list