[cairo] [PATCH 62/72] drm/i915: split image_caches array into struct for better readability
Enrico Weigelt, metux IT consult
enrico.weigelt at gr13.net
Tue Dec 29 07:46:49 PST 2015
On 29.12.2015 16:04, Chris Wilson wrote:
> Or you could use named indices.
Named indices ? you mean #defines's or enum ?
IMHO, that would make it more compilicated, and I haven't seen any
reason why that should be an array at all.
> Anyway image_caches is a dead end.
> Having a cache for in-flight images is useful, but the high level
> decision of what to cache for long periods of time is best left to the
> client. And the closest we have to a clean texture atlas interface are
So, what shall I do here instead ?
>> - caches = &device->image_caches;
>> + caches = &(device->image_caches.a8);
> Please reduce the number of random brackets in the patches.
The brackets after the & ?
I intentionally added them to make it more clear to the human
reader, what we're going to reference here.
metux IT consulting
More information about the cairo