[cairo] CAIRO_STATUS_WIN32_GDI_ERROR on windows when drawing text

Plugin Everything jameswhiffin at gmail.com
Thu Aug 1 05:21:50 UTC 2019

Hello All

I have a plugin that runs in two host apps, Adobe After Effects and
Premiere Pro. The code works perfectly fine in After Effects, but
frequently returns GDI Error on Premiere despite being the same code.

I posted the issue on the Premiere forums and the mod said *"Yes, my
primary suspect would be Windows font handling. Let me know if you
determine that the problem is with our APIs."* I thought I'd ask on here
first to see if anyone has any experience overcoming such an issue as
google is barren with results relating to the error.

Here's the code:

        status = cairo_status(cr);

        if (status)
            statusString = cairo_status_to_string(status);

        cairo_move_to(cr, x, y);
        cairo_show_text(cr, metaDataV.at(i).c_str());

The fonts I tried:

"Arial", "Courier New", "Tahoma", "Times New Roman", "Verdana"

I also tried using the more advanced glyph system however the issue
persisted. Any help would be appreciated. Thank you.


*James Whiffin* | *Developer*
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cairographics.org/archives/cairo/attachments/20190801/9588789c/attachment.html>

More information about the cairo mailing list