[cairo-bugs] [Bug 103559] Incorrect code generation for atomic operations if HAVE_INTEL_ATOMIC_PRIMITIVES defined

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Thu Nov 16 19:52:21 UTC 2017


--- Comment #9 from Adrian Johnson <ajohnson at redneon.com> ---
(In reply to Bill Spitzak from comment #8)
> Therefore calling these "GCC_LEGACY" is probably wrong.

Why is it wrong? That is exactly what the gcc manual refers to them as:


> I'm thinking they should be called "ICC" (the name of the Intel C
> Compiler is ICC)

We are talking about gcc builtins. Why would we call them "ICC"?

> or maybe IIPsABI using the initial of the document title,
> or some variation of that.

The gcc manual says they should not be used for new code. So I don't see the
point of coming up with any name other than something intended to discourage
use of them like "legacy" or "obsolete".

You are receiving this mail because:
You are the QA Contact for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cairographics.org/archives/cairo-bugs/attachments/20171116/8ac4aa78/attachment.html>

More information about the cairo-bugs mailing list